Servers are showing a Certificate Invalid error

Incident Report for Scilife

Postmortem

The issue had to do with an approval action that needs to be carried out over email before an SSL certificate renewal takes place.
This approval email was overlooked and the SSL certificate was not automatically renewed which caused the error.
The issue was resolved in a few minutes after the problem was identified and has been logged as an official incident in our quality system to perform proper root cause analysis and avoid it from happening in the future.

Posted Mar 28, 2021 - 17:04 UTC

Resolved

Our servers are showing a certificate expired error when trying to login.
Posted Mar 28, 2021 - 15:22 UTC